portupgrade error2006年04月16日 10時04分06秒

portupgrade を使っていると以下の様なエラーが出ることがある。

--->  Upgrading 'p5-HTML-Parser-3.45' to 'p5-HTML-Parser-3.50' (www/p5-HTML-Pars
er)
--->  Building '/usr/ports/www/p5-HTML-Parser'
===>   p5-HTML-Parser-3.50 depends on file: /usr/local/lib/perl5/site_perl/5.8.8
/HTML/Tagset.pm - found
===>   p5-HTML-Parser-3.50 depends on file: /usr/local/bin/perl5.8.8 - found
===>   p5-HTML-Parser-3.50 depends on file: /usr/local/lib/perl5/site_perl/5.8.8
/Test/More.pm - found
===>   p5-HTML-Parser-3.50 depends on file: /usr/local/lib/perl5/site_perl/5.8.8
/URI.pm - not found
===>    Verifying install for /usr/local/lib/perl5/site_perl/5.8.8/URI.pm in /us
r/ports/net/p5-URI
===>  Installing for p5-URI-1.35
===>   p5-URI-1.35 depends on file: /usr/local/bin/perl5.8.8 - found
===>   Generating temporary packing list
===>  Checking if net/p5-URI already installed
===>   p5-URI-1.35 is already installed
      You may wish to ``make deinstall'' and install this port again
      by ``make reinstall'' to upgrade it properly.
      If you really wish to overwrite the old port of net/p5-URI
      without deleting it first, set the variable "FORCE_PKG_REGISTER"
      in your environment or the "make install" command line.
*** Error code 1

Stop in /usr/ports/net/p5-URI.
*** Error code 1

Stop in /usr/ports/www/p5-HTML-Parser.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade35345.24 ma
ke
** Fix the problem and try again.

今使っているバージョンは 20041226_7。最新のものは 2.0.1_1 になっている。新しいものでは、もう直っているのかも知れない。

このエラーは、portupgrade がどうも依存関係を拾い切れていない為に出るようだ。そこで、一度 pkg_delete をし、make install をすると、うまくいく。

ここで、portupgrade でインストールするとどうなるかは試したことが無いので、判らない。ただ、依存関係が既に壊れている状態なので、-O は付けないと無理だとは思う。

コメント

コメントをどうぞ

※メールアドレスとURLの入力は必須ではありません。 入力されたメールアドレスは記事に反映されず、ブログの管理者のみが参照できます。

※なお、送られたコメントはブログの管理者が確認するまで公開されません。

名前:
メールアドレス:
URL:
コメント:

トラックバック

このエントリのトラックバックURL: http://uyota.asablo.jp/blog/2006/04/16/329023/tb

※なお、送られたトラックバックはブログの管理者が確認するまで公開されません。